Seleccionar idioma:
Realizar Donación - Mods Premium - Portfolio



Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.
* Error en Hide Tag Special
  Leído 1542 veces
* Viendo el foro
 0 Usuarios y 1 Visitante están viendo este foro.


Tema Solucionado
*
Feb 10 2013


Buenas, ayer instalé este magnifico mod. Pero tengo un problema, a la hora de instalarlo me daba un error en post.php pero aun asín lo instalé. El mod funciona bien y oculta el contenido que quiero pero lo que pasa es que cuando un usuario responde el tema para ver los links en vez de irse directamente al contenido oculto se va para su propio comentario y eso es muy molesto. Puede ser que eso no funcione bien por el error que dio al instalar? haber si me ayudáis, gracias.

Mi foro con un tema oculto: http://www.universogame.net/pal/lo-imposible-(dvd5)(pal)(esp-esingles)(2012)(2host)

Para que veáis lo que os digo.

ADK Portal
2.0.5
http://www.universogame.net

Mensajes: 101

Ver Perfil  Universo Game  Email 

En línea

*
Feb 10 2013


no entender muy bien a lo q te refieres, cuando decis que un usuario responde y se va para su comentario  :o

Pero de por si ese error debio haber sido solucionado, despues de haber instalado dicho mod.
haber si explicas bien a que te refieres con lo primero, y para ver lo del error dale en desinstalar (pero no lo desinstales)
simplemente chekea en q parte se ven los errores

Adk Portal
2.0 RC5
en construccion
#1

Mensajes: 181

Ver Perfil 

En línea

*
Feb 10 2013


Me refiero cuando un usuario responde el tema que en vez de que se valla a su comentario se valla al contenido oculto, por que por ejemplo a los que respondan y ya estén por la segunda página es muy incomodo tener que darle de nuevo a la primera (todo esto si es posible de hacerse)

Y esto son los errores que me dio

*


Gracias.





ADK Portal
2.0.5
http://www.universogame.net
#2

Mensajes: 101

Ver Perfil  Universo Game  Email 

En línea

*
Feb 10 2013


en el nro 5 del Post.php, tenias que buscar:

Código: [Seleccionar]
if ($smcFunc['htmltrim'](strip_tags(parse_bbc($_POST['message'], false), '<img>')) === '')
y reemplzar por:

Código: [Seleccionar]
// Okay i will say there is something, so that i check for an real empty post :)
$context['user_post_avaible'] = 1;

if ($smcFunc['htmltrim'](strip_tags(parse_bbc($_POST['message'], false), '<img>')) === '')

intentado haciendo eso, pero antes has una copia de tu archivo a modificar

PD: es algo que no me habia fijado, yo antes instale ese mod, archivo por archivo manualmente,
y ahora que chekeo tbm me manda al ultimo mensaje, y eso que tengo la opcion activada:

" Regresar, por defecto, a los temas después de publicar un mensaje"

temas y diseño > opciones de usario > tu theme > Reiniciar los valores por defecto (visitante) para este tema

Adk Portal
2.0 RC5
en construccion
#3

Mensajes: 181

Ver Perfil 

« Última Modificación: Febrero 10, 2013, 11:43:32 am por Principiante1 »
En línea

*
Feb 10 2013


No encuentro eso que dices que hay que buscar. Seré muy torpe en esto, de adjunto el post.php por si quieres mirarlo tu.

Unido automaticamente - {Febrero 10, 2013, 10:53:44 pm}


Al final hay alguna solución?

ADK Portal
2.0.5
http://www.universogame.net
#4

Mensajes: 101

Ver Perfil  Universo Game  Email 

« Última Modificación: Febrero 10, 2013, 10:53:44 pm por game »
En línea

*
Feb 12 2013


Nadie me dice nada?  :-\

ADK Portal
2.0.5
http://www.universogame.net
#5

Mensajes: 101

Ver Perfil  Universo Game  Email 

En línea

*
Feb 12 2013
uge


El que te adjunto tiene esa parte bien modificada. Prueba que no te de ningún error.

#6

Mensajes: 222

Ver Perfil 

En línea

*
Feb 14 2013


Al intentar desinstalarlo me dio el mismo error. Pero bueno, gracias, no creo que aya solución para esto.

Saludos.

ADK Portal
2.0.5
http://www.universogame.net
#7

Mensajes: 101

Ver Perfil  Universo Game  Email 

En línea

*
Feb 14 2013


A cual supuesto error haces mencion?

Al responder te llevara a donde vos tengas seleccionado en las opciones de tu perfil, a tu respuesta o al indice de foros.
Porque lo que vos estas haciendo es responder un tema, sin importar si es para ver un contenido oculto o no. No tiene relacion el contenido oculto con la accion que realiza despues de responder.

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#8

Mensajes: 13978

Ver Perfil  SMFPersonal 

En línea

*
Feb 14 2013
uge


Al intentar desinstalarlo me dio el mismo error. Pero bueno, gracias, no creo que aya solución para esto.

Saludos.

Evidentemente. Porque esa parte del código te la he añadido yo. El error es porque tú en lugar de tener esto

Código: [Seleccionar]
if ($smcFunc['htmltrim'](strip_tags(parse_bbc($_POST['message'], false), '<img>')) === '')
Tienes esto

Código: [Seleccionar]
if ($smcFunc['htmltrim'](strip_tags(parse_bbc($_POST['message'], false), '<img><object><embed>')) === '' && (!allowedTo('admin_forum') || strpos($_POST['message'], '[html]') === false))
Eso es porque un mod te ha modificado esa parte. Entonces si al desinstalar el mod a ti te busca lo de arriba y tienes lo de abajo pues te tira el error.

Si aún quieres desinstalarlo totalmente, es decir, quitando la parte del código que te da error al desinstalar. Sólo busca en tu post.php esto y lo eliminas.

Código: [Seleccionar]
// Okay i will say there is something, so that i check for an real empty post :)
$context['user_post_avaible'] = 1;
#9

Mensajes: 222

Ver Perfil 

En línea




Otros temas de su interes




Usuario:
Contraseña:
Sesión:
hermes bracelet replica, christian louboutin replica, van cleef and arpels replica, red bottoms replica, cartier love bracelet replica christian louboutin replica, christian louboutin replica, hermes bracelet replica,