Seleccionar idioma:
Realizar Donación - Mods Premium - Portfolio



Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.
* Problema en mensajes
  Leído 995 veces
* Viendo el foro
 0 Usuarios y 1 Visitante están viendo este foro.


Tema Solucionado
*
Mar 08 2015


Hola amigos!!

He tenido un problema con mi foro, que en los 2 años que lo tengo, nunca lo tube, así que no se porque pueda ser el problema.
Ayer estaba ayudando a un usuario que dejó un código en mi foro y yo lo mejoré indicándole las mejores que hice y lo que le recomendé, etc. el tema que ahora este usuario me dice de que el código que yo hice, no funciona... en si tenía un pequeño fallo que ya está solventado, cuando pueda lo pondré en el Foro... la cuestión es que cuando copio el código que le dejé ayer justamente para probarlo ahora y revisarlo porque fallaba, porque yo una vez que ayudo, elimino esos códigos de mi pc, cuando lo cargo en mi mIRC (programa), logro ver que la razón de una expulsión de un usuario de prueba que ingresé a un canal, salía así:

*


es decir que salía la razón, pero sin colores... por eso se ven esos números en la razón:

(4[1Ban automático4] 1Nick inapropiado para el canal, cámbieselo 4Normas: 1)

esos números, representan colores y además de los números, también hay símbolos, de negrita, subrayado y de color, la razón con esos números de colores y esos símbolos sería así:

*


lo pongo para que puedan ver los símbolos ya que en el Foro no se visualizan, son invisibles.

así se ve en el editor del programa que uso para crear/modificar códigos.

y la razón con colores debería salir así:

*


Bueno... explico así de extenso y de detallado para que no haya dudas...
El problema que tengo ahora es que los símbolos de negrita, colores y subrayado se han borrado de los mensajes de mi Foro, no de todos, pero si de la gran mayoría, estube revisando mensaje de diferentes fechas y cuando copio los códigos para ver si han perdido también esos símbolos, logro ver que algunos si tienen y que otros no lo tienen, la gran mayoría no lo tienen, es decir que por alguna extraña razón se han eliminado, no tengo idea de porqué pueda haber pasado esto, pero necesito solucionarlo, jamás tube este problema, es más no tengo idea de cuando puede haber empezado este problema, he revisado un backup reciente que tengo, y los códigos de colores si salen perfectamente en los mensajes y me imagino que en todos, por ejempo en mi Foro los mensajes que no tienen esos símbolos, los veo en la base de datos del backup y si están ahí, osea que se han eliminado muy recientemente.

El día 2 de marzo fué el día que este usuario publicó su código porque tenía un fallo, y desde ese día aparentemente comenzó este extraño problema, ya que hoy cuando copié el código que dejé ayer, no estaban esos símbolos.
Cuando copio el primer mensaje del tema, que sería el mensaje de este usuario, no tiene los símbolos  :o cuando yo el día 2 de marzo lo copié al código de este usuario, y si tenía los colores.

No se porque ha pasado esto, solucionarlo, puedo hacerlo, importando la base de datos que tengo hasta el día 1 de febrero de este año y los códigos ya estarían con sus símbolos correspondientes. Pero... voy a perder los mensajes y usuarios que he tenido desde 1 de febrero hasta la fecha actual, ese es el tema.

¿Porqué pasó esto?, ¿Hay alguna manera fácil de sobreescribir los mensajes viejos por los nuevos? o ¿de qué manera podría solucionar este inconveniente?

Por lo que deduzco, este problema pasó hoy, porque esta mañana me quedé hasta masomenos hasta las 6 de la mañana y todo estaba OK, cuando copié el código hoy a las 4 de la tarde, ya no estaban esos símbolos.

Aclaro que no toqué nada, más que desinstalar el mod nCode Image Resizer 1.4 y hacer la modificación que me indicó Heracles, que funciona de pelos, anda muy bien.
De ahí no toqué más nada, no configuré nada, no toqué la base de datos, tampoco cambié el idioma del foro, no hice nada de nada, ninguna modificación, excepto la que me indicó Heracles.
Además hice todas las pruebas necesarias para saber si realmente esos símbolos han sido eliminados, probé con Firefox y no están, copié y pegué en Notepad++ y no están, así que fueron eliminados.

Desde ya amigos, muchas gracias!!!

Foro de Ayuda de Programación General, IRC y mIRC Scripting 

Ninguno
2.0.14
http://www.argentinairc.net/foro/

Mensajes: 560

Ver Perfil  Ayuda de Programación General, IRC y mIRC Scripting 

« Última Modificación: Marzo 08, 2015, 07:43:15 pm por Príncipe_Azul »
En línea

*
Mar 08 2015


Tendrias que ver si tu servidor no cambio alguna configuracion y que por ello te este pasando esto.. Si no modificaste nada en tu sitio es ilogico que empiece a funcionar de otra manera..

Tendrias que ponerte en contacto con ellos...

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#1

Mensajes: 13978

Ver Perfil  SMFPersonal 

En línea

*
Mar 08 2015


Me acaba de pasar de nuevo...

Estaba modificando un mensaje, le había puesto un código con colores, y cuando modifiqué varias veces ese mensaje, copio el código y no están esos símbolos!!! se siguen borrando, yo he usado la modificación esa que no te carga la página donde está el editor, osea la modificación rápida, quizás sea eso.. pero ¿porqué en los otros mensajes están borrados los símbolos, y en la base de datos no lo está?

O sea... me sigue borrando esos símbolos, algo está pasando, porque siempre usé ese botón para modificar un mensaje (modificación rápida) y nunca tube problemas, ahora me ha vuelto a pasar, se ha borrado  :-\ pero ¿porqué justamente esos 2 símbolos? si podría ser otro, porque exactamente esos 2 (o 3 en el caso de que haya subrayado) !!!!

Y lo peor es que se borró de la base de datos !!! porque podrían borrarse por algún archivo que los esté borrando.

Ya mismo voy a preguntar en mi hosting, ya nomás lo hago a ver si ellos instalaron algo o modificaron alguna regla o algo hicieron para que ahora me pase esto.

Muchas gracias amigo!!

Y si alguien quiere aportar algo más, bienvenido sea!! :) :)

PD: Voy a bajar la base de datos para ver si están borrados los símbolos realmente, así confirmo finalmente que están borrados.


Editado: Confirmado, los símbolos están borrados en la base de datos.

Foro de Ayuda de Programación General, IRC y mIRC Scripting 

Ninguno
2.0.14
http://www.argentinairc.net/foro/
#2

Mensajes: 560

Ver Perfil  Ayuda de Programación General, IRC y mIRC Scripting 

« Última Modificación: Marzo 08, 2015, 08:42:20 pm por Príncipe_Azul »
En línea

*
Mar 08 2015


Podrias pasarme un codigo de ejemplo en un archivo txt asi pruebo en mi localhost.

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#3

Mensajes: 13978

Ver Perfil  SMFPersonal 

En línea

*
Mar 08 2015


Si amigo cláro que si.

Te paso 2 archivos, uno es el código original que tengo en una base de datos vieja (que si tiene los símbolos) y el otro es el mismo código que tengo en el Foro, pero este ya no tiene los símbolos.

Comento que en la base de datos que tengo de la fecha 1 de febrero de este año, ví un código que no tiene los símbolos, pero si busco otra db más vieja, si los tiene, o sea que se van borrando, algo bastante extraño, quizás este problema ya lo tenía desde siempre o desde hace tiempo y recién hoy me doy cuenta.

Muchas gracias como siempre hermano!!

Foro de Ayuda de Programación General, IRC y mIRC Scripting 

Ninguno
2.0.14
http://www.argentinairc.net/foro/
#4

Mensajes: 560

Ver Perfil  Ayuda de Programación General, IRC y mIRC Scripting 

« Última Modificación: Marzo 08, 2015, 10:45:36 pm por Príncipe_Azul »
En línea

*
Mar 08 2015


Estás usando utf8 en el foro?

2.0.12
#5

Mensajes: 1070

Ver Perfil  Email 

En línea

*
Mar 08 2015


Si amigo.

Foro de Ayuda de Programación General, IRC y mIRC Scripting 

Ninguno
2.0.14
http://www.argentinairc.net/foro/
#6

Mensajes: 560

Ver Perfil  Ayuda de Programación General, IRC y mIRC Scripting 

En línea

*
Mar 08 2015


Yo probe los dos codigos en mi localhost, si bien en el mensaje no se persiben dichos caracteres, al copiar el codigo y pegarlo en el editor si aparecen..

Edito: Aca te dejo los dos codigos para que veas, aca no se veran los caracteres, pero si copias el primer codigo y lo pegas en tu editor veraz que si sale bien el codigo.

Código: [Seleccionar]
on 100:text:*:#: {
  if (#Argentina == #) {
    if ($strip($1) == .addnick) {
      if ($read(%ListaNicks.dir,w,$2) == $null) {
        write %ListaNicks.dir $2
        msg # 2El nick4 $2 2ha sido agregado.
      }
      else msg # 3El nick4 $2 3ya existe!
    }
    if ($strip($1) == .delnick) {
      if ($read(%ListaNicks.dir,w,$2) != $null) {
        write -dl $+ $readn %ListaNicks.dir
        msg # 2El nick4 $2 2ha sido borrado.
      }
      else msg # 3El nick4 $2 3No existe
    }
  }
}

Código: [Seleccionar]
on 100:text:*:#: {
  if (#Argentina == #) {
    if ($strip($1) == .addnick) {
      if ($read(%ListaNicks.dir,w,$2) == $null) {
        write %ListaNicks.dir $2
        msg # 2El nick4 $2 2ha sido agregado.
      }
      else msg # 3El nick4 $2 3ya existe!
    }
    if ($strip($1) == .delnick) {
      if ($read(%ListaNicks.dir,w,$2) != $null) {
        write -dl $+ $readn %ListaNicks.dir
        msg # 2El nick4 $2 2ha sido borrado.
      }
      else msg # 3El nick4 $2 3No existe
    }
  }
}

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#7

Mensajes: 13978

Ver Perfil  SMFPersonal 

« Última Modificación: Marzo 08, 2015, 11:18:57 pm por ^HeRaCLeS^ »
En línea

*
Mar 08 2015


Cláro amigo, en el editor del Foro no se ven, pero en el bloc de notas y en Notepad++ si se ven, pero el problema no es que se vean o no, el problema es que se están eliminando de la base de datos, algo rarísimo...

O osea yo comprobé porque miré mi base de datos actual, y varios códigos no tienen los símbolos, pero cuando miro una bd más vieja, si los tiene, es más, abro la base de datos con Notepad++ y ahí puedo verlos perfectamente (si es que existen, cláro).

No se que puede ser que esté haciendo que se borren, aclaro que los contenidos de los mensajes, están intactos, lo único que pasa, o sea el único problema es que en algunos mensajes, esos símbolos no están, cuando estaban por supuesto, es como si fuese que jamás estuvieron, pero obviamente si estaban ya que yo copio los códigos de los usuarios y los pego en mi editor y si los veo correctamente, es algo bastante raro.

Podría volver a dejar los mensajes con esos códigos, por más laburo que me lleve, pero eso no es la solución, ya que puede volver a pasar y borrarse nuevamente esos símbolos.

Saludos y muchas gracias amigo!!!

Foro de Ayuda de Programación General, IRC y mIRC Scripting 

Ninguno
2.0.14
http://www.argentinairc.net/foro/
#8

Mensajes: 560

Ver Perfil  Ayuda de Programación General, IRC y mIRC Scripting 

En línea

*
Mar 08 2015


Como te dije, debe ser algo que modificaron en el servidor, si vos no editaste nada en tu sitio no puede actuar distinto a como lo hacia... Y como te mostre en mi localhost y aca, no es problema de smf ya que sino aca pasaria lo mismo..

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#9

Mensajes: 13978

Ver Perfil  SMFPersonal 

En línea




Otros temas de su interes

modificar imagen de rangos pipi2010 Julio 06, 2011, 04:07:27 pm
Como hacer un redireccionamiento completo de URLs amigables? daviloco Junio 05, 2012, 05:17:42 pm
Ayuda con Sd Automatic index piola2.0 Febrero 16, 2012, 07:38:54 pm
¿Cómo eliminar los Mensajes informados? Príncipe_Azul Noviembre 30, 2014, 07:28:13 pm
mensaje de bien venida en mi foro calorro Abril 08, 2015, 02:25:12 pm *
como se hace esto?? Juanillo Diciembre 25, 2009, 07:10:10 pm *



Usuario:
Contraseña:
Sesión:
hermes bracelet replica, christian louboutin replica, van cleef and arpels replica, red bottoms replica, cartier love bracelet replica christian louboutin replica, christian louboutin replica, hermes bracelet replica,