Seleccionar idioma:
Realizar Donación - Mods Premium - Portfolio



Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.
* Problemas con acentos en instalación limpia
  Leído 1711 veces
* Viendo el foro
 0 Usuarios y 1 Visitante están viendo este foro.


*
Abr 03 2013


Hola amigos, no se que ocurre... el último mensaje que deje era sobre un problema de acentos en los nombres y descripciones al crear/modificar foros... pues bien, me ha ocurrido dos cosas que me tienen mosqueado.

Al instalar el Adk Cover Post no me coge la instalación en el archivo modifications.spanish_es.php, probé con el *.zip de SMF como el que hay aquí y nada... recuerdo que en la anterior vez que reinstalara todo esto no me ocurrió. Bueno lo hago manualmente y voy e instalo el Tagging System For Topics, bueno pues se instala correctamente y tal y los acentos me los muestra como caracteres...

Mi foro no está en UTF-8 ya que odio eso de estar poniendo el código para mostrar los acentos, etc... siempre instalo sin marcar esa casilla de UTF-8 y nunca he tenido problemas con los archivos de lenguaje, osea si yo pongo áéíóú pues debe mostrarse correctamente.

Otra cosa rara, es que del archivo */Themes/default/languages/Modifications.spanish_es.php es de donde me coge mal los caracteres, luego el archivo */Themes/default/languages/Tags.spanish_es.php de ahí si me muestra bien los acentos... que locura no? :/


La verdad es que no se que ocurre... no se si es en el PhpMyAdmin que tengo que cambiar algo pero ya me estoy desquiciando de verdad...

Saludos.



EDITO: Esto es de locura joder, meto el archivo modifications_spanish_es.php del anterior foro, que tenína una copia de seguridad y ahora si me coge bien el acento.......... por eso al instalar el Adk Cover Post no cogía el archivo para meterle la configuración. Que les puede pasar a esos archivos? :/

Ahora he probado a descomprimir el archivo Modification.spanish_es.php del smf_2-0-4_spanish_es y lo he vuelto a subir con la traducción del Tagged System y volvio a salir mal los caracteres... es como si esos archivos traen algo defectuoso pero es una locura ya que son iguales al de mi anterior foro, solo trae dentro:

Código: [Seleccionar]
<?php
// Version: 2.0; Modifications


?>

Como ya os he comentado, metiendo el del backup coge los acentos correctamente... alguien que pueda decirme que ocurre, porque si el zip estuviera roto no se dejaría descomprimir no? Madre mía xD

Acabo de probar a crear manualmente un Modifications.spanish_es.php, metí el código de la traducción del MOD y sigue sin mostrar bien los caracteres, es solamente con el archivo anterior que tenía del backup que detecta bien los áéíóú ...que diferencia puede haber entre ese archivo (tanto el que cree yo así como el que me baje de SMF que es el bueno por así decirlo) y los que tenía guardados del backup¿? Además como ya comenté antes, del Tags.spanish_es.php si me coge bien los áéíóú :/

------------------------------------------------------------------------------------------>


Bueno he revisado el archivo a fondo con el Notepad++ y resulta que los archivos de descarga del sitio SMF, los Spanish_es vienen codificados en UTF-8¿??¿¿? he descomprimido y le he puesto la codificación ANSI y ahora si funciona. Me toca descomprimir y cambiarle la codificación a todos. Esto es un error del que subió el pack?

Ahora que lo pienso, esto tendrá algo que ver el porque me ocurre este fallo?

http://www.smfpersonal.net/bugs-errores/ayuda-con-cosas-raras-que-me-hace-el-foro-por-los-acentos-t6920.0.html;msg46641#msg46641

Saludos.

*

SimplePortal 2.3.5
2.0.4
http://www.darken.es

Mensajes: 76

Ver Perfil  DaRKeN.es 

« Última Modificación: Abril 03, 2013, 06:08:59 am por DaRKeN »
En línea

*
Abr 04 2013


El problema es por la codificacion de los archivos, no de los contenidos en si.

No se como estaran guardando los packs de idioma en smf, pero tendrias que asegurarte que todos esten con la codificacion que usas en el sitio.

Con respecto a lo que decis del otro tema, pues si, si los archivos estan en otra codificacion no guardara bien los datos.
El otro tema lo cierro y seguimos todo por aca.

PD: Muevo el tema a la seccion correcta, porque esta seccion es paga bugs de smfpersonal.

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#1

Mensajes: 13978

Ver Perfil  SMFPersonal 

En línea

*
Abr 04 2013


Ok, mil gracias por poner el post en el sitio indicado y cerrar el otro. Pues algún archivo estará con otra codificación, porque en la barra de título del navegador me muestra así &eacute; la é pero si pongo é enla creación del foro pues como ya comenté me desaparece y para evitar eso pues lo pongo así G&eacute;nero aunque en la barra de título pues se muestra con el código html... que rollo.


Pero lo más chungo es que es una instalación limpia, con todo recién bajado de la página oficial, la BDD limpia, etc.. jaja bueno no todo puede ser perfecto, iré revisando a ver si saco donde esta el fallo y seguiré comentando según vaya averiguando.

Saludos.

*

SimplePortal 2.3.5
2.0.4
http://www.darken.es
#2

Mensajes: 76

Ver Perfil  DaRKeN.es 

En línea

*
Abr 07 2013


Si decis que ese idioma te da conflictos proba con otro idioma, por ejemplo el spanish_latin
Otra cosa a tener en cuenta es la hora de editar archivos, espero que no estes usando el bloc de notas porque eso no sirve para editar codigos.

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#3

Mensajes: 13978

Ver Perfil  SMFPersonal 

En línea

*
Abr 07 2013


Si voy a ir probando a ver que tal. Para editar archivos uso Notepad++ :)

Gracias fiera.

*

SimplePortal 2.3.5
2.0.4
http://www.darken.es
#4

Mensajes: 76

Ver Perfil  DaRKeN.es 

En línea

*
Abr 07 2013


Vos pensaras porque no te digo todas las cosas juntas, pero si te digo todo junto nunca llegaremos al problema, tenemos que ir paso por paso para poder ir descartando cosas.

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#5

Mensajes: 13978

Ver Perfil  SMFPersonal 

En línea

*
Abr 09 2013


Por supuesto, poquito a poco con buena letra jeje  ;)

Muchas gracias ^HeRaCLes^

*

SimplePortal 2.3.5
2.0.4
http://www.darken.es
#6

Mensajes: 76

Ver Perfil  DaRKeN.es 

En línea




Otros temas de su interes

Colocar perfil en filas benjazTHU Julio 20, 2019, 02:11:04 pm
ayuda a implementar un toolbar semiwarez Febrero 14, 2010, 07:48:56 pm
Botón toogle, desactivarlo Aficiones Septiembre 16, 2014, 06:44:16 pm *
AYUDA CON COLOR EN EL PERFIL SUPERIOR DERECHA SINIK Marzo 13, 2017, 12:17:52 pm *
Error en los post sombra_21 Diciembre 08, 2013, 07:50:39 pm
URLs entendibles en smf (con simplesef)... ¿valdrá la pena? luuuciano Diciembre 19, 2013, 04:44:22 pm



Usuario:
Contraseña:
Sesión:
hermes bracelet replica, christian louboutin replica, van cleef and arpels replica, red bottoms replica, cartier love bracelet replica christian louboutin replica, christian louboutin replica, hermes bracelet replica,