Seleccionar idioma:
Realizar Donación - Mods Premium - Portfolio



Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.
* Problemas con AdkPortal 2.1.1
  Leído 1355 veces
* Viendo el foro
 0 Usuarios y 1 Visitante están viendo este foro.


Tema Solucionado
*
Ago 28 2012


Hola! Actualicé hace poco el portal y últimamente me ha estado arrojando problemas, tantos que me llena el log. Principalmente estos dos:

Aplicar filtro: Mostrar sólo los mensajes de error de esta URL
http://www.ardiforos.com.ar/...
Aplicar filtro: Mostrar sólo los mensajes de error con este mensaje
8: Undefined variable: txt
Aplicar filtro: Mostrar sólo los errores de este archivo
Archivo: /...Subs-adkfunction.php(2146) : eval()'d code
Línea: 65

Código: [Seleccionar]
54function analizar_type($type, $body)
55{
56 if ($type == 'bbc')
57 echo parse_bbc($body);
58 elseif ($type == 'html')
59 echo un_htmlspecialchars($body);
60 elseif ($type == 'php')
61 {
62 $body = trim($body);
63 $body = trim($body, '<?php');
64 $body = trim($body, '
?>
');
65 eval($body);
66 }
67}
En mi ignorancia pregunto, ese "?>" tiene que estar ahí?, porke cuando lo borré se acomodó el código en mi phpeditor.

Y este otro:

Aplicar filtro: Mostrar sólo los mensajes de error de esta URL
http://www.ardiforos.com.ar/...
Aplicar filtro: Mostrar sólo los mensajes de error con este mensaje
8: Undefined index: foro
Aplicar filtro: Mostrar sólo los errores de este archivo
Archivo: /.../Load.php
Línea: 1670
Aplicar filtro: Mostrar sólo los mensajes de error de este usuario Visitante
Aplicar filtro: ...

Código: [Seleccionar]
1650: 'is_lighttpd' => isset($_SERVER['SERVER_SOFTWARE']) && strpos($_SERVER['SERVER_SOFTWARE'], 'lighttpd') !== false,
1651: 'is_nginx' => isset($_SERVER['SERVER_SOFTWARE']) && strpos($_SERVER['SERVER_SOFTWARE'], 'nginx') !== false,
1652: 'is_cgi' => isset($_SERVER['SERVER_SOFTWARE']) && strpos(php_sapi_name(), 'cgi') !== false,
1653: 'is_windows' => strpos(PHP_OS, 'WIN') === 0,
1654: 'iso_case_folding' => ord(strtolower(chr(138))) === 154,
1655: 'complex_preg_chars' => @version_compare(PHP_VERSION, '4.3.3') != -1,
1656: );
1657: // A bug in some versions of IIS under CGI (older ones) makes cookie setting not work with Location: headers.
1658: $context['server']['needs_login_fix'] = $context['server']['is_cgi'] && $context['server']['is_iis'];
1659:
1660: // Detect the browser. This is separated out because it's also used in attachment downloads
1661: detectBrowser();
1662:
1663: //Adk Portal Modifications
1664: global $adkportal;
1665: if((!empty($_REQUEST['topic']) || !empty($_REQUEST['board'])) && !empty($adkportal['adk_enable'])){
1666:
1667: $url = $adkportal['adk_enable'] == 1 ? $scripturl.'?action=forum' : $scripturl;
1668: array_unshift($context['linktree'], array(
1669: 'url' => $url,
==>1670: 'name' => $txt['foro']
1671: ));
1672: }
1673:
1674: //Modified by lucas-ruroken
1675: // Set the top level linktree up.
1676: array_unshift($context['linktree'], array(
1677: 'url' => $scripturl,
1678: 'name' => $context['forum_name_html_safe']
1679: ));
1680:
1681: // This allows sticking some HTML on the page output - useful for controls.
1682: $context['insert_after_template'] = '';
1683:
1684: if (!isset($txt))
1685: $txt = array();
1686: $simpleActions = array(
1687: 'findmember',
1688: 'helpadmin',
1689: 'printpage',
1690: 'quotefast',

No sé si son bugs o qué, espero puedan ayudarme.

Saludos!

adk 2.1
2.0.2
www.ardiforos.com.ar

Mensajes: 352

Ver Perfil  ArdiForos 

« Última Modificación: Septiembre 03, 2012, 03:10:40 pm por nodensdorian »
En línea

*
Ago 28 2012


1º No quites ese codigo, ya que es el encargado de cerrar los codigos en los bloques.
2º El primer error del que hablas seguramente viene de algun bloque el cual esta usando variables $txt, pero no esta globalizada la variable.
3º El segundo error, te debe estar faltando la variable de texto esa y por eso da el error.
En el archivo modifications.tu_idioma.php pone lo siguiente:
Código: [Seleccionar]
$txt['foro'] = 'Foro';

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#1

Mensajes: 13978

Ver Perfil  SMFPersonal 

En línea

*
Ago 29 2012


El del Load parece que se solucionó, pero el del Subs-adkfunction.php persiste, kité dos blokes que saké de otro lado, a ver si es eso y comento. Gracias por las pronta respuesta Heracles :)

Unido automaticamente - {Agosto 30, 2012, 12:36:49 am}


Sí, al final el problema eran esos dos blokes que puse pertenecientes a otro portal. Muchas gracias Heracles! Te debo una grande de muzza :P jaja.

Abrazos!

adk 2.1
2.0.2
www.ardiforos.com.ar
#2

Mensajes: 352

Ver Perfil  ArdiForos 

« Última Modificación: Agosto 30, 2012, 12:36:49 am por nodensdorian »
En línea




Otros temas de su interes

Extreme Download System DUDA Aluki Octubre 18, 2010, 06:09:33 pm *
Necesito de su ayuda... Genius Enero 31, 2013, 10:27:40 am
como programar una $variable o un script pipi2010 Enero 02, 2011, 03:50:31 pm
Error en ADK portal 2.0 RC9 jacker95 Agosto 14, 2011, 01:11:26 pm *
[Duda] Poner Imagen Immanence Junio 30, 2011, 08:57:12 pm
Problema Con Adk Portal Fernando Neira Design Octubre 27, 2012, 05:16:03 am *



Usuario:
Contraseña:
Sesión:
hermes bracelet replica, christian louboutin replica, van cleef and arpels replica, red bottoms replica, cartier love bracelet replica christian louboutin replica, christian louboutin replica, hermes bracelet replica,