Seleccionar idioma:
Realizar Donación - Mods Premium - Portfolio



Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.
* Warnig en la cabecera de la web relacionado al Load.php
  Leído 1578 veces
* Viendo el foro
 0 Usuarios y 1 Visitante están viendo este foro.


Tema Solucionado
*
Feb 08 2015


Buenos días comunidad.

Luego de mucho tiempo nuevamente necesito de su valiosa ayuda.

Gracias por su tiempo, les detallo mi problema:

Debido a situaciones que pasan debí migrar a un host gratuito, hice todo lo de rutina para estos casos y en fin, una vez que la web quedó accesible en el nuevo host me dio una serie de errores que fui solucionando hasta que me trabé con uno...

Al pasar el reparir_settings y después de hacerlo me dio un warning relacionado con el cache, luego de revisar me di cuenta que esta ruta debía cambiarla manuamente en el settings.php ya que el repair no lo hizo. Como sea, eso lo solucioné.

Luego de arreglar el diseño de la web y "reiniciar las rutas de los temas" desde la administración el foro quedó listo, excepto por un detalle, y es que en el foro, subforos y post del portal en el encabezado me sale el siguiente warning:

Código: [Seleccionar]
Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/u174396568/public_html/Sources/Load.php(183) : runtime-created function on line 3

*


Además, como aprecian en la imagen, los textos se ven un poco más grandes, todo esto menos en la página principal que ahí no sale nada de eso.


A este punto no sé qué será, quizás sea sencillo o quizás no, en todo caso no tengo ni idea así que acudo a ustedes a ver si dan con el asunto. (y)


PD: Adjunto el Load.php (?)
Web: kurayamireborn.com
Theme: Inferno
smf 2.0.2

Saludos y esperaré por su ayuda.

2.0.9

Mensajes: 31

Ver Perfil  KurayamiReborn 

« Última Modificación: Febrero 08, 2015, 01:37:31 pm por Jota »
En línea

*
Feb 08 2015


Hola amigo Jota, bueno yo mucho no se del tema, pero solucionar ese error no es difícil, el error indica que la función preg_replace() está obsoleta, así que debés usar en su lugar preg_replace_callback(), este errror es muy común.

Bueno, la verdad lo de migrar a un hosting gratuito creo que siempre te dará problemas, ojalá que no, pero yo uso 000webhost y realmente y disculpen, pero es pécimo, muy lento, por ahí se desconecta el FTP y hay que esperar hasta que se pueda conectar de nuevo, tiene muchos cuelgues y eso que tengo un Foro totalmente sin usuarios y sin visitantes.

Bueno amigo Jota, aquí te dejo adjunto el archivo Load.php, pruébalo y cuéntanos si has solucionado al menos este error que comentás en este Tema.

Saludos!!

Foro de Ayuda de Programación General, IRC y mIRC Scripting 

Ninguno
2.0.14
http://www.argentinairc.net/foro/
#1

Mensajes: 560

Ver Perfil  Ayuda de Programación General, IRC y mIRC Scripting 

En línea

*
Feb 08 2015


Hola, gracias por responder.

Si lo pones así pues sí, resulta sencillo. ja...

Subí el archivo que me pasaste y ahora tira algo diferente:

Código: [Seleccionar]
Warning: preg_replace_callback(): Requires argument 2, '$smcFunc['entity_fix']('\2')', to be a valid callback in /home/u174396568/public_html/Sources/Load.php(183) : runtime-created function on line 3



Edito: Estoy usando Hostinger, este tiene algo de aguante a pensar de ser gratis.

2.0.9
#2

Mensajes: 31

Ver Perfil  KurayamiReborn 

« Última Modificación: Febrero 08, 2015, 01:55:21 pm por Jota »
En línea

*
Feb 08 2015


Pensaba que se iba a solucionar con eso, disculpame, pero es mejor que alguien con más experiencia te ayude, ya no se que puede ser.  :(

Disculpame amigo.

Foro de Ayuda de Programación General, IRC y mIRC Scripting 

Ninguno
2.0.14
http://www.argentinairc.net/foro/
#3

Mensajes: 560

Ver Perfil  Ayuda de Programación General, IRC y mIRC Scripting 

En línea

*
Feb 08 2015


Pensaba que se iba a solucionar con eso, disculpame, pero es mejor que alguien con más experiencia te ayude, ya no se que puede ser.  :(

Disculpame amigo.


No hay problema, más bien gracias por echarme la mano y tomarte el tiempo.  +10


Por aquello, pondré de nuevo el Load.php original a ver si comenzamos de nuevo.  8)

2.0.9
#4

Mensajes: 31

Ver Perfil  KurayamiReborn 

En línea

*
Feb 08 2015


El problema esta en que estas utilizando la version de smf 2.0.2 sobre una version de php superior o igual a 5.4.

Para poder solucionar esto tenes que actualizar a la version de smf 2.0.9

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#5

Mensajes: 13978

Ver Perfil  SMFPersonal 

En línea

*
Feb 08 2015


Hola Heracles.

Vaya lío pero para nada me quejo... de todos modos creo que ya tocaba actualizar...

Gracias por la respuesta, sólo tengo unas dudas sobre eso a ver si puedo en este mismo tema:

1- Según leí, debo ir actualizando versión por versión hasta llegar a la 2.0.9
2- Encontré esto http://custom.simplemachines.org/upgrades/?language=spanish_es-utf8

¿Qué me recomiendas? ¿Deberé bajar el paquete o basta con hacerlo manualmente (buscar y reemplazar)?
Por ejemplo el primero, del smf 2.0.2 al smf 2.0.3 http://custom.simplemachines.org/upgrades/index.php?action=upgrade;file=smf_patch_2.0.3.tar.gz;smf_version=2.0.2

3- ¿Al actualizar perderé los mods o sripts?

Espero que me aclares o guíes con esto para proceder a actualizar.

Saludos.

2.0.9
#6

Mensajes: 31

Ver Perfil  KurayamiReborn 

« Última Modificación: Febrero 08, 2015, 04:16:40 pm por Jota »
En línea

*
Feb 08 2015


Los idiomas no hace falta que los toques ya que no hay cambios de idiomas entre las versiones...

Para actualizar tenes que ir de version en version...
2.0.2 a 2.03
2.0.3 a 2.0.4
2.0.4 a 2.0.5
2.0.5 a 2.0.6
2.0.6 a 2.0.7
2.0.7 a 2.0.8
2.0.8 a 2.0.9
Realizando las actualizaciones de este modo no perderas ningun mod instalado... Puede que alguna actualizacion te de algun fallo, en ese caso venis y nosotros te ayudamos a solucionar dicho fallo.

Otra forma de actualizar seria hacer un full upgrade a la version 2.0.9, pero de este modo si perderias todo.

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#7

Mensajes: 13978

Ver Perfil  SMFPersonal 

En línea

*
Feb 09 2015


Hola nuevamente.

Al fin terminé de actualizar el foro a la versión 2.0.9 y no tuve ningún problema por dicha, así que todo quedó perfecto.  :D

Como nota a partir de la versión 2.0.7 se quitó el error.


Muchas gracias amigo Heracles como siempre das en el clavo.  (y)


Saludos a tod@s y marco como solucionado este tema.

2.0.9
#8

Mensajes: 31

Ver Perfil  KurayamiReborn 

En línea

*
Feb 10 2015


Me alegro que se haya solucionado!

*¤×•·:.·.:·•×¤* ^HeRaCLeS^ *¤×•·:.·.:·•×¤*
*¤×• Todos los Mp seran ignorados | Solo seran considerados los Mp Solicitados por mi •×¤*
*¤×• All Mp will be ignored | Only considers the Mp requested per my •×¤*

SMFPersonal

Adk Portal 3.0.2
2.0.14
www.smfpersonal.net
#9

Mensajes: 13978

Ver Perfil  SMFPersonal 

En línea




Otros temas de su interes

Ayuda con permisos jasiels Abril 23, 2015, 01:36:54 pm *
[Ayuda] Tarea programadas y tablas. Immanence Diciembre 22, 2012, 03:02:12 am
Solucionar Log Errores Chemaaa Febrero 01, 2011, 12:47:35 pm *
A algunos usuarios no le aparece la imagen captcha al responder Tamagochi Enero 29, 2011, 06:21:44 am
Modicar el editor de respuesta rapidas Ax5 Jersito Febrero 20, 2013, 10:30:29 pm *
Como configurar estas etiquetas en mi foro? Erick cuenca Agosto 02, 2016, 10:49:43 pm



Usuario:
Contraseña:
Sesión:
hermes bracelet replica, christian louboutin replica, van cleef and arpels replica, red bottoms replica, cartier love bracelet replica christian louboutin replica, christian louboutin replica, hermes bracelet replica,